Search This Blog

Total Pageviews

Monday, December 20, 2010

Debugging tips for SharePoint

Thanks Vince.

http://blog.thekid.me.uk/archive/2007/07/25/debugging-tips-for-sharepoint-and-wss-exceptions.aspx

Sharepoint Development Tips

Read the Value of a Field in a List Item
http://msdn.microsoft.com/en-us/library/ff521580.aspx

Converting Date and Time Values
http://msdn.microsoft.com/en-us/library/ms197282.aspx

Describing Forms of URL Strings
http://msdn.microsoft.com/en-us/library/ms431831.aspx

Getting References to Sites, Web Applications, and Other Key Objects
http://msdn.microsoft.com/en-us/library/ms468609.aspx

Add or Delete List Items
http://msdn.microsoft.com/en-us/library/ms467435.aspx

How to: Return Items from a List
http://msdn.microsoft.com/en-us/library/ms456030.aspx

 Run Code on All Web Servers
http://msdn.microsoft.com/en-us/library/ff464297.aspx

Registering and Importing Namespaces
http://msdn.microsoft.com/en-us/library/ms431098.aspx

SharePoint Development Tasks
http://msdn.microsoft.com/en-us/library/ee536204.aspx

SharePoint Interview Questions

http://www.dotnetfunda.com/interview/exclusive/showcatquestion.aspx?category=8

http://www.pointsharepoint.com/2008/03/sharepoint-interview-questions.html

http://programmingsharepoint.blogspot.com/2008/02/sharepoint-interview-questions.html

http://it.toolbox.com/wiki/index.php/Sharepoint_Interview_questions

SharePoint 2010 Interview Questions 

http://mysharepointwork.blogspot.com/2010/01/sharepoint-2010-interview-questions_20.html

http://www.interviewhelper.org/categorydetail.php?Cat=33&level=1&title=Sharepoint

Thursday, December 16, 2010

Error occured in deployment step 'Recycle IIS Application Pool': Invalid namespace



solution :
The solution was to: open the Turn Windows on or off menu in the Control Panel (under Programs), and enable WMI compatibility. The path to the feature is:


Internet Information Services -> Web Management Tools -> IIS 6 Management Compatibility -> IIS 6 WMI Compatibility

Friday, December 10, 2010

Site Logo Not Changing on Web Part Pages

I tested and reproduced your issue in my local machine.
Since the Web Part Pages would override the content in PlaceHolderPageTitleInTitleArea place holder, the site logo would not change automatically.
So would you please try remove or comment the following control TitleBarWebPart:


See the similar scenario and solution:
http://emanonsolutions.blogspot.com/2010/02/left-navigation-webpart-pages.html

Hope this can help.

Site Logo Not Changing on Web Part Pages

I tested and reproduced your issue in my local machine.
Since the Web Part Pages would override the content in PlaceHolderPageTitleInTitleArea place holder, the site logo would not change automatically.
So would you please try remove or comment the following control TitleBarWebPart:


See the similar scenario and solution:
http://emanonsolutions.blogspot.com/2010/02/left-navigation-webpart-pages.html

Hope this can help.